Вопрос задан 13.06.2020 в 21:00.
Предмет Информатика.
Спрашивает Плотникова Мария.
Напишите программу на паскале. В программу вводят 3 числа, например 15 28 10, и она должна
выбрать среднею из них. т. е если дается 15 28 10 она должна выписать 15Ответы на вопрос
Отвечает Llorens Natasha.
var a,b,c: integer;
begin
readln (a,b,c);
if ((a > b) and (a < c)) or ((a < b) and (a > c)) or ((a<b) and (b=c)) or ((a<b) and (a=c)) or ((a<c) and (a=b)) then writeln(a)
else if ((b > a) and (b < c)) or ((b < a) and (b > c)) then writeln(b)
else writeln(c);
end.
Отвечает Турсумбаева Дарья.
// процедура обмена значений переменных а и b
procedure swapp(var a,b:integer);
var c: integer;
begin
c:=a;
a:=b;
b:=c;
end;
// основная программа
var a,b,c: integer;
begin
write('числа a b c через пробел: ');
readln(a,b,c);
if a>b then swapp(a,b);
if b>c then swapp(b,c);
writeln('среднее по значению: ',b);
end.
Ввод -вывод:
числа a b c через пробел: 25 14 18
среднее по значению: 18
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
