Вопрос задан 04.06.2018 в 00:47. Предмет Информатика. Спрашивает Иштуганов Тимур.

Составить программу, которая вычисляет произведение сомножителей:

(1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… Вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. В ответе написать количество сомножителей для данного вычисления. В ответе указать только число, например, 15
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Косова Снежана.

Var i, ans : integer;
pr : real;
begin
    i := 1;
    pr := 1;
    ans := 0;
    while (pr <= 3.6) do begin
        pr *= (1 + 1 / (i * i));
        i := i + 1;
        ans := ans + 1;
    end;
    writeln(ans);
end.

48 сомножителей

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос