Вопрос задан 15.05.2020 в 20:39. Предмет Информатика. Спрашивает Занковец Максим.

Уровень B. Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в

диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет.Пример:Массив: -5 -6 2 3 -3 0 8 -3 0 9Что ищем: 0A[9] = 0на паскале(старая версия)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лебединцева Мария.

Примерно так:

program Poisk;

const

N = 10;

type

mas = array [-10..N] of integer;

var

a: mas;

x: integer;

i: integer;

begin

readln (x);

for i := 1 to x do

a[i] := random (10);

for i := 1 to x do

begin

if (a[i] = 0) then

writeln ('a',i,' := ',a[i])

else

writeln ('Такого индекса нету');

end;

end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос