
Вопрос задан 05.05.2020 в 03:52.
Предмет Информатика.
Спрашивает Слюсар Неля.
Напишите программу для суммы числового ряда. Дан числовой ряд и малая величина е(эпсила). Найдите
сумму ряда с точностью е(0,001), общий член которого задан формулой

Ответы на вопрос

Отвечает Штебнер Яночка.
Чтобы излишне не терять точность и не тратить лишнее время на вычисления, выведем рекуррентную формулу.
![\displaystyle a_1= \frac{3}{2}; \\ \\ a_{i-1}=\frac{3^{i-1}\cdot (i-1)!}{[2(i-1)]!}; \\ \\ a_i=\frac{3^i\cdot i!}{(2i)!} = \frac{3\cdot3^{i-1}\cdot i\cdot(i-1)!}{2 i\cdot(2i-1)\cdot(2i)!}={ \frac{3i}{2i\cdot(2i-1)}\cdot a_{i-1}=\frac{3}{4i-2}\cdot a_{i-1} \displaystyle a_1= \frac{3}{2}; \\ \\ a_{i-1}=\frac{3^{i-1}\cdot (i-1)!}{[2(i-1)]!}; \\ \\ a_i=\frac{3^i\cdot i!}{(2i)!} = \frac{3\cdot3^{i-1}\cdot i\cdot(i-1)!}{2 i\cdot(2i-1)\cdot(2i)!}={ \frac{3i}{2i\cdot(2i-1)}\cdot a_{i-1}=\frac{3}{4i-2}\cdot a_{i-1}](https://tex.z-dn.net/?f=%5Cdisplaystyle%20a_1%3D%20%5Cfrac%7B3%7D%7B2%7D%3B%20%5C%5C%20%5C%5C%20a_%7Bi-1%7D%3D%5Cfrac%7B3%5E%7Bi-1%7D%5Ccdot%20%28i-1%29%21%7D%7B%5B2%28i-1%29%5D%21%7D%3B%20%5C%5C%20%20%5C%5C%20%20a_i%3D%5Cfrac%7B3%5Ei%5Ccdot%20i%21%7D%7B%282i%29%21%7D%20%20%20%20%3D%20%5Cfrac%7B3%5Ccdot3%5E%7Bi-1%7D%5Ccdot%20i%5Ccdot%28i-1%29%21%7D%7B2%20i%5Ccdot%282i-1%29%5Ccdot%282i%29%21%7D%3D%7B%20%5Cfrac%7B3i%7D%7B2i%5Ccdot%282i-1%29%7D%5Ccdot%20a_%7Bi-1%7D%3D%5Cfrac%7B3%7D%7B4i-2%7D%5Ccdot%20a_%7Bi-1%7D)
В задании не сказано точно, как определять условие окончания суммирования. Примем, что суммирование завершается, если очередной член ряда не может изменить накопленную сумму больше, чем на ε, т.е.
|aₓ| ≤ ε.
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (ai1,eps,s,i):=(3/2,0.001,3/2,2);
while true do begin
var a:=3/(4*i-2)*ai1;
if Abs(a)>eps then begin i+=1; s+=a; ai1:=a end
else Break
end;
Writeln('S = ',s:0:3)
end.
Результат
S = 2.532
В задании не сказано точно, как определять условие окончания суммирования. Примем, что суммирование завершается, если очередной член ряда не может изменить накопленную сумму больше, чем на ε, т.е.
|aₓ| ≤ ε.
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (ai1,eps,s,i):=(3/2,0.001,3/2,2);
while true do begin
var a:=3/(4*i-2)*ai1;
if Abs(a)>eps then begin i+=1; s+=a; ai1:=a end
else Break
end;
Writeln('S = ',s:0:3)
end.
Результат
S = 2.532



Отвечает Калугина Диана.
//Pascal
//Функция факториала
function fact(n: integer): real;
begin
if (n = 0) then fact := 1
else fact := n * fact(n - 1);
end;
//Main
var
a: real;
n, lim: integer;
begin
write('Введите n: '); readln(n);
lim := n; a := 0;
for n := 1 to lim do
begin
//a := a + (power(3,n)*fact(n))/fact(2*n);
a := a + (exp(ln(3)*n)*fact(n))/(fact(2 * n));
end;
writeln('a = ', a:5:3);
readln;
end.
//Функция факториала
function fact(n: integer): real;
begin
if (n = 0) then fact := 1
else fact := n * fact(n - 1);
end;
//Main
var
a: real;
n, lim: integer;
begin
write('Введите n: '); readln(n);
lim := n; a := 0;
for n := 1 to lim do
begin
//a := a + (power(3,n)*fact(n))/fact(2*n);
a := a + (exp(ln(3)*n)*fact(n))/(fact(2 * n));
end;
writeln('a = ', a:5:3);
readln;
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili