 
Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до
1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке Pascal желательно 0
        0
         0
        0
    Ответы на вопрос
 
        uses crt;
var
X: array[-1000..1000] of integer;
S,i,k: integer;
begin
clrscr;
writeln('Введите массив X:');
for i:=1 to 10 do
begin
write('X[',i:2,'] ==> ');
readln(X[i])
end;
for i:=1 to 10 do
write(X[i],' ');
writeln;
K:=0;
for i:=1 to 10 do
begin
S:=X[i] mod 3;
if S = 0 then
K:=K+1
end;
writeln('Ответ: ',K)
end.
 0
                    0
                     0
                    0
                 
        i,k: integer;
begin
....
k:=0;
все в цикле (примерно так: for i:=1 to 10 do...)(это чтобы прокручивать цикл)
if ((a[i] mod 2=1) and (a[i] mod 3=0)) then k=k+1;
writeln(k);end.
что-то вроде этого,я уже точно не помню язык pascal;
 0
                    0
                     0
                    0
                 
            Программа на языке Pascal, которая находит количество нечетных элементов массива, делящихся на 3:
```pascal program CountOddDivisibleByThree; var arr: array[1..10] of integer; count: integer; i: integer; begin count := 0; // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to 10 do begin readln(arr[i]); end; // Подсчет количества нечетных элементов, делящихся на 3 for i := 1 to 10 do begin if (arr[i] mod 2 <> 0) and (arr[i] mod 3 = 0) then begin count := count + 1; end; end; // Вывод результата writeln('Количество нечетных элементов, делящихся на 3: ', count); end. ```
В данной программе объявляется массив `arr` из 10 элементов и переменная `count` для подсчета количества нечетных элементов, делящихся на 3. Затем происходит ввод элементов массива с клавиатуры. Далее, с помощью цикла `for` происходит перебор элементов массива и проверка, является ли текущий элемент нечетным и делится ли на 3 без остатка. Если оба условия выполняются, то значение `count` увеличивается на 1. В конце программы выводится результат подсчета.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			