Вопрос задан 24.04.2020 в 14:31.
Предмет Информатика.
Спрашивает Игнатюк Лиза.
Задача 1 (в тетради для дз) Написать программу, обрабатывающую поток водимых с клавиатуры целых
чисел (пока не будет введен 0) и выводящую на экран количество введенных чисел, количество положительных, а также сумму и среднее арифметическое только положительных. Задачу можно решать через любой оператор цикла (кроме for). Формат вывода: Введено чисел_ Из них положительных_ Сумма положительных чисел_ Среднее арифметическое положительных чисел_Ответы на вопрос
Отвечает Паринова Даша.
var a,k,p,s: integer;
begin
repeat
write('Введите число: ');
readln(a);
if a<>0 then k:=k+1;
if a>0 then
begin
p:=p+1;
s:=s+a
end
until a=0;
writeln;
writeln ('Введено чисел_',k);
writeln ('Из них положительных_',p);
writeln ('Сумма положительных чисел_',s);
writeln ('Среднее арифметическое положительных чисел_',s/p:0:3);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
