Вопрос задан 05.04.2020 в 11:09.
Предмет Информатика.
Спрашивает Сорокопудова Анастасия.
Две целочисленный массив из 30 элементов . Элементы массива могут принимать целые значения о 0 до
100 -баллы учащихся выпускного класса за итоговый тестер информатике .составьте программу которая позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе ((( СРОЧнО))Ответы на вопрос
Отвечает Зинина Диана.
Program n1;
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
