Вопрос задан 28.01.2020 в 05:06.
Предмет Информатика.
Спрашивает Кошарная Арина.
Составить программу, которая бы запрашивала Хнач и Хкон и определяла произведение всех
положительных чисел от Хнач до Хкон (решить задачу, используя цикл с предусловием – While .. Do). Пож помогитеОтветы на вопрос
Отвечает Мануйлов Родион.
//Pascal WDE
Var
xk,xn:real;
i,r,xik,xin:integer;
b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
begin
r:=r*i;
b:=true;
end;
inc(i);
end;
if b=true then write(r) else write('0');
end.
Пример ввода:
-2.8
3.8
Пример вывода:
6
Var
xk,xn:real;
i,r,xik,xin:integer;
b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
begin
r:=r*i;
b:=true;
end;
inc(i);
end;
if b=true then write(r) else write('0');
end.
Пример ввода:
-2.8
3.8
Пример вывода:
6
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
