Вопрос задан 25.01.2020 в 22:07.
Предмет Информатика.
Спрашивает Кириенко Михаил.
Составить программу для решения квадратного уравнения a*x*x+b*x+c=0
Ответы на вопрос
Отвечает Харюков Антон.
Var
a, b, c, D: integer;
x, x2: real;
begin
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
D := sqr(b) - 4 * a * c;
if D > 0 then begin
x := (-b - sqrt(D)) / 2 * a;
x2 := (-b + sqrt(D)) / 2 * a;
writeln('x1 = ', x, newline, 'x2 = ', x2);
end;
if D < 0 then writeln('Корней нет.');
if D = 0 then begin
x := (-b) / 2 * a;
writeln('x = ', x);
end;
end.
a, b, c, D: integer;
x, x2: real;
begin
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
D := sqr(b) - 4 * a * c;
if D > 0 then begin
x := (-b - sqrt(D)) / 2 * a;
x2 := (-b + sqrt(D)) / 2 * a;
writeln('x1 = ', x, newline, 'x2 = ', x2);
end;
if D < 0 then writeln('Корней нет.');
if D = 0 then begin
x := (-b) / 2 * a;
writeln('x = ', x);
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
