Вопрос задан 21.01.2020 в 10:31. Предмет Информатика. Спрашивает Товстопятая Аня.

Составьте программу на языке Паскаля , которая находит сумму наименьшего и наибольшего из 3

введенных с экрана числа
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шашков Данил.
Это, если не учитывать, что введённые числа могут быть одинаковы


program p17;
var
x, x1, x2: integer;
a,a1,a2: integer;
beginwrite ('Введите число: ');
readln (x);
write ('Введите число: ');
readln (x1);
write ('Введите число: ');
readln (x2);
if (x>x1) and (x>x2) then a:=x 
else if (x1>x) and (x1>x2) then a:=x1 
else if (x2>x) and (x2>x1) then a:=x2;  

if (x<x1) and (x<x2) then a1:=x 
else if (x1<x) and (x1<x2) then a1:=x1 
else if (x2<x) and (x2<x1) then a1:=x2;

a2:=a+a1;
writeln ('Cумма самого большого и самого маленького числа, введённого вами: ',a2);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль, которая находит сумму наименьшего и наибольшего из трех введенных с экрана чисел, может выглядеть следующим образом:

```pascal program MinMaxSum; var num1, num2, num3, min, max, sum: integer; begin writeln('Введите три числа:'); readln(num1, num2, num3); // Находим минимальное число min := num1; if num2 < min then min := num2; if num3 < min then min := num3; // Находим максимальное число max := num1; if num2 > max then max := num2; if num3 > max then max := num3; // Считаем сумму минимального и максимального чисел sum := min + max; writeln('Сумма наименьшего и наибольшего чисел: ', sum); end. ```

В этой программе мы сначала запрашиваем у пользователя три числа с помощью `readln`. Затем мы находим минимальное и максимальное число с помощью условных операторов `if`. Наконец, мы суммируем минимальное и максимальное число и выводим результат с помощью `writeln`.

Примечание: В данной программе предполагается, что пользователь будет вводить только целые числа. Если требуется обработка вещественных чисел, необходимо использовать соответствующий тип данных и изменить соответствующие операции сравнения.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос