
Написать программу, вычисляющую среднее арифметическое N чисел, введенных с клавиатуры. Цикл for;
pascal.

Ответы на вопрос

var b: Integer;
var a: array[1..n] of integer;
begin
for var i := 1 to n do
begin
Read(a[i]);
b+=a[i];
end;
Writeln(b/n);
end.



Для решения данной задачи на языке программирования Pascal можно использовать цикл for и переменные. Ниже приведен пример программы, которая вычисляет среднее арифметическое n чисел, введенных с клавиатуры:
```pascal Program Average;
Var n, i, number: Integer; sum, average: Real;
Begin Write('Введите количество чисел: '); ReadLn(n); sum := 0; For i := 1 to n do Begin Write('Введите число ', i, ': '); ReadLn(number); sum := sum + number; End; average := sum / n; WriteLn('Среднее арифметическое = ', average:0:2); End. ```
Программа сначала запрашивает у пользователя количество чисел n. Затем в цикле for от 1 до n программа запрашивает ввод числа и прибавляет его к переменной sum. После окончания цикла программа вычисляет среднее арифметическое, разделив сумму чисел на их количество, и выводит результат на экран.
Заметим, что в данной программе используются переменные n (количество чисел), i (переменная цикла), number (введенное пользователем число), sum (сумма чисел) и average (среднее арифметическое).


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili