1)составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных
чисел. Pascal 2)составьте программу вычисления суммы элементов от первого отрицательного и до конца. PascalОтветы на вопрос
program massiv1;
uses CRT;
var i,N,P:integer;
a:array [1..N] of integer;
begin
P:=1;
read(N);
for i:=1 to N do
begin
read a[i];
end;
for i:=1 to N do
begin
if a[i] >o
then
P:=P*a[i];
end;
write(P);
readkey;
end.
1) Программа вычисления произведения положительных чисел в массиве А:
``` var A: array of Integer; n, i: Integer; product: Integer;
begin Write('Введите размер массива: '); Readln(n);
SetLength(A, n); for i := 0 to n - 1 do begin Write('Введите элемент массива A[', i, ']: '); Readln(A[i]); end;
product := 1; for i := 0 to n - 1 do begin if A[i] > 0 then product := product * A[i]; end;
WriteLn('Произведение положительных чисел в массиве А: ', product); end. ```
2) Программа вычисления суммы элементов от первого отрицательного до конца:
``` var A: array of Integer; n, i, sum: Integer; foundNegative: Boolean;
begin Write('Введите размер массива: '); Readln(n);
SetLength(A, n);
for i := 0 to n - 1 do begin Write('Введите элемент массива A[', i, ']: '); Readln(A[i]); end;
foundNegative := False; sum := 0;
for i := 0 to n - 1 do begin if foundNegative then sum := sum + A[i] else if A[i] < 0 then foundNegative := True; end;
WriteLn('Сумма элементов от первого отрицательного до конца: ', sum); end. ```
В обоих программах пользователю сначала предлагается ввести размер массива, затем элементы массива. Затем программа выполняет требуемые действия с массивом и выводит результат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
