Составьте программу на паскале для упорядочения пяти чисел по убыванию и нахождение их суммы
Ответы на вопрос
A: array [1 .. 5] of real;
i, j: byte;
sum, tmp: real;
begin
sum := 0;
{ Заполнение массива }
for i := 1 to 5 do
begin
write('A[', i, '] = ');
readln(A[i]);
sum := sum + A[i]; // подсчет суммы
end;
writeln(#13 + 'Сумма элементов = ', sum);
{ Сортировка по убыванию }
for i := 1 to 4 do
for j := i + 1 to 5 do
if A[i] < A[j] then
begin
tmp := A[i];
A[i] := A[j];
A[j] := tmp;
end;
{ Вывод }
writeln('Отсортированный массив: ');
for i := 1 to 5 do
write(' ', A[i]);
end.
Конечно, я могу помочь вам с написанием программы на Pascal для упорядочения пяти чисел по убыванию и нахождения их суммы. Вот пример программы:
```pascal program OrderAndSum; var numbers: array[1..5] of Integer; i, j, temp, sum: Integer; begin // Ввод чисел writeln('Введите пять чисел:'); for i := 1 to 5 do begin write('Число ', i, ': '); readln(numbers[i]); end;
// Упорядочивание чисел по убыванию for i := 1 to 4 do for j := i + 1 to 5 do if numbers[i] < numbers[j] then begin temp := numbers[i]; numbers[i] := numbers[j]; numbers[j] := temp; end;
// Вывод упорядоченных чисел writeln('Числа в порядке убывания:'); for i := 1 to 5 do write(numbers[i], ' '); writeln;
// Нахождение суммы чисел sum := 0; for i := 1 to 5 do sum := sum + numbers[i];
// Вывод суммы writeln('Сумма чисел: ', sum);
readln; end. ```
Программа сначала запрашивает у пользователя ввод пяти чисел, затем сортирует их в порядке убывания и выводит на экран упорядоченные числа и их сумму. Обратите внимание, что данная программа использует простой алгоритм сортировки "пузырьком".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
