Вопрос задан 19.01.2020 в 20:54.
Предмет Информатика.
Спрашивает Кадуцкий Никита.
Написать программу вычисления n!
Ответы на вопрос
Отвечает Воронова София.
var
n, fact: word; //fact - факториал числа
i: integer;
begin
fact:= 1; //Присваиваем начальное значение
writeln('Введите число n');
readln(n);
for i:= 1 to n do //Для i, равного от 1 до n умножаем значение fact на i
fact:= fact * i;
writeln(n, '! = ', fact);
end.
Отметь решение, как лучшее, плиз)
Отвечает Павлов Вадик.
program factorial; function fact(n: integer): longint; begin if (n = 0) then fact := 1 else fact := n * fact(n - 1); end; var n: integer; begin for n := 0 to 16 do writeln(n, '! = ', fact(n)); end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Факториал числа n обозначается как n! и представляет собой произведение всех натуральных чисел от 1 до n. Например, 5! = 5 * 4 * 3 * 2 * 1 = 120.
Для вычисления факториала числа n можно использовать цикл или рекурсию. Давайте рассмотрим решение с помощью цикла.
Программа на языке Python для вычисления фактори
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
