Помогите кто знает С#напечатать программу, в котором вводятся двухзначные! числа, которые делятся
на 4, но не делятся на 6.Ответы на вопрос
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text.RegularExpressions;
namespace Rextester
{
public class Program
{
public static void Main(string[] args)
{
for(int i = 10; i < 100; i++)
if(i % 4 == 0 && i % 6 != 0)
Console.WriteLine(i);
}
}
}
Конечно, я могу помочь вам написать программу на C#, которая выполняет указанные условия. Вот пример простой консольной программы:
```csharp using System;
class Program { static void Main() { Console.WriteLine("Введите двухзначное число, которое делится на 4, но не делится на 6:");
// Ввод первого числа Console.Write("Введите первое число: "); int number1 = int.Parse(Console.ReadLine());
// Проверка, является ли число двухзначным и делится на 4, но не делится на 6 if (IsTwoDigit(number1) && DivisibleByFour(number1) && !DivisibleBySix(number1)) { Console.WriteLine($"Число {number1} подходит условиям."); } else { Console.WriteLine($"Число {number1} не соответствует условиям."); }
// Ввод второго числа Console.Write("Введите второе число: "); int number2 = int.Parse(Console.ReadLine());
// Проверка, является ли число двухзначным и делится на 4, но не делится на 6 if (IsTwoDigit(number2) && DivisibleByFour(number2) && !DivisibleBySix(number2)) { Console.WriteLine($"Число {number2} подходит условиям."); } else { Console.WriteLine($"Число {number2} не соответствует условиям."); }
Console.ReadLine(); // Чтобы консольное окно не закрывалось сразу после выполнения программы }
// Метод для проверки, является ли число двухзначным static bool IsTwoDigit(int num) { return num >= 10 && num <= 99; }
// Метод для проверки, делится ли число на 4 static bool DivisibleByFour(int num) { return num % 4 == 0; }
// Метод для проверки, не делится ли число на 6 static bool DivisibleBySix(int num) { return num % 6 == 0; } } ```
Программа запрашивает у пользователя два двузначных числа, затем проверяет их на соответствие условиям (делится на 4, но не делится на 6) и выводит результаты.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
