Вопрос задан 18.01.2020 в 19:00. Предмет Информатика. Спрашивает Ливенский Саша.

На языке Паскаль Составьте программу вывода на экран номера этажа и номеров квартир ,находящихся на

данном этаже,девятиэтажного дома ,на каждом этаже которого находится по 5 квартир
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сарочан Максим.
Var i,j,n: integer;
begin
for i := 1 to 9 do
  begin
  write(i,': ');
  for j:=1 to 5 do
    begin
    n:=n+1;
    write(n,' ');
    end;
  writeln;
  end
end.  
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, которая выводит номера этажа и номера квартир на каждом этаже девятиэтажного дома, где на каждом этаже по 5 квартир:

```pascal program ВыводНомеровКвартир;

const КоличествоЭтажей = 9; // Общее количество этажей КвартирНаЭтаже = 5; // Количество квартир на каждом этаже

var Этаж, НомерКвартиры: Integer;

begin // Внешний цикл для прохода по каждому этажу for Этаж := 1 to КоличествоЭтажей do begin // Внутренний цикл для прохода по каждой квартире на текущем этаже for НомерКвартиры := 1 to КвартирНаЭтаже do begin // Вывод номера этажа и номера квартиры на экран writeln('Этаж ', Этаж, ', Квартира ', НомерКвартиры); end; end;

// Ожидание нажатия клавиши перед завершением программы readln; end. ```

Эта программа использует два вложенных цикла: внешний цикл проходит по каждому этажу, а внутренний цикл проходит по каждой квартире на текущем этаже. Внутри вложенных циклов программа выводит на экран номер этажа и номер квартиры.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос