
ИНФОРМАТИКА!!! Написать программу определения числа билетов с 6-значными номерами,у которых сумма
первых 3 десятичных цифр равна сумме 3 последних десятичных цифр (ПАСКАЛЬ)

Ответы на вопрос

uses crt;
Var s,a,b,v,z,i:longint;
Begin s:=1; {учитываем билет с номером 000000}
for i:=1 to 999999 do {перебираем билеты от 000001 до 999999}
begin
v:=i;
z:=0;
while z<3 do begin
z:=z+1;
a:=v mod 10 +a; v:=v div 10 end; {считаем сумму последних трех чисел}
while z<6 do begin z:=z+1;
b:=v mod 10 +b;
v:=v div 10
end; {считаем сумму первых трех чисел}
if a=b then s:=s+1;
a:=0;
b:=0;
end;
writeln(s);
ReadKey;
end.



Конечно, я могу помочь вам написать программу на языке Паскаль для определения числа билетов с 6-значными номерами, у которых сумма первых 3 десятичных цифр равна сумме 3 последних десятичных цифр. Вот пример такой программы:
``` program TicketNumber;
var ticket: integer; firstThreeDigits, lastThreeDigits: integer; sumFirstThree, sumLastThree: integer;
begin writeln('Введите 6-значный номер билета: '); readln(ticket); // Получаем первые и последние три десятичных цифры номера билета firstThreeDigits := ticket div 1000; lastThreeDigits := ticket mod 1000; // Считаем сумму первых и последних трех десятичных цифр sumFirstThree := (firstThreeDigits div 100) + ((firstThreeDigits div 10) mod 10) + (firstThreeDigits mod 10); sumLastThree := (lastThreeDigits div 100) + ((lastThreeDigits div 10) mod 10) + (lastThreeDigits mod 10); // Проверяем, равны ли суммы первых и последних трех десятичных цифр if sumFirstThree = sumLastThree then writeln('У билета номер ', ticket, ' сумма первых трех десятичных цифр равна сумме последних трех десятичных цифр.') else writeln('У билета номер ', ticket, ' сумма первых трех десятичных цифр не равна сумме последних трех десятичных цифр.'); readln; end. ```
Вы можете скопировать этот код в свою среду разработки на Паскале и запустить программу. После запуска, программа попросит вас ввести 6-значный номер билета, а затем выдаст результат, равны ли суммы первых трех десятичных цифр номера билета сумме последних трех десятичных цифр.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili