НАДО НАПИСАТЬ ПРОГРАММУ В PASCAL Программа проводит анкетирование студентов. Студенты вводят Ю -
если он юноша, Д - если девушка и количество баллов за экзамен (от 1 до 70 баллов). Программа должны выдать в какую группу попал этот чел: девушки, набравшие меньше или равно 35 баллов идут в группу технологов, а больше 35 баллов - в группу менеджеров; юноши набравшие больше 35 баллов идут на инженера, а набравшие меньше или равно 35 баллов - в металлургиюОтветы на вопрос
var sex:string;
points:integer;
begin
writeln('Введите пол');
readln(sex);
writeln('Введите кол-во баллов');
readln(points);
if sex = 'Д' then begin
if points <= 35 then
writeln('В группу технологов')
else
writeln('В группу менеджеров');
end
else begin
if points <= 35 then
writeln('В группу металургов')
else
writeln('В группу инженеров');
end;
end.
Привет! Я могу помочь тебе написать программу на Pascal для проведения анкетирования студентов. Вот пример кода:
```pascal program Anketirovanie;
var gender: char; score: integer;
begin writeln('Добро пожаловать на анкетирование студентов!'); writeln('Пожалуйста, введите ваш пол (Ю - юноша, Д - девушка): '); readln(gender); writeln('Введите количество баллов за экзамен (от 1 до 70): '); readln(score);
if (gender = 'Ю') and (score > 35) then writeln('Вы попали в группу инженеров.') else if (gender = 'Ю') and (score <= 35) then writeln('Вы попали в группу металлургии.') else if (gender = 'Д') and (score > 35) then writeln('Вы попали в группу менеджеров.') else if (gender = 'Д') and (score <= 35) then writeln('Вы попали в группу технологов.') else writeln('Введены некорректные данные.');
writeln('Спасибо за участие в анкетировании!'); end. ```
В этой программе мы сначала запрашиваем у студента его пол и количество баллов за экзамен. Затем, используя условные операторы if-else, мы определяем, в какую группу попал студент в зависимости от его пола и количества баллов.
- Если студент является юношей (вводит 'Ю') и набрал больше 35 баллов, то он попадает в группу ин
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
