Вопрос задан 16.01.2020 в 15:07. Предмет Информатика. Спрашивает Банкетов Егор.

Напишите легкую программу на Паскале пожалуйста. Напишите программу которая в последовательности

нат. чисел определяет сумму чисел оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число оканчивающейся на 5. Количество чисел не превышает 100. Введённые числе по модулю не превышают 300. Программа должна вывести одно число: сумму чисел оканчивающихся на 5. Входные данные 3 15 25 24 Выходные данные 40
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Корягина Ангелина.
Program suma;
Var a:array [1..100] of integer;
    k, i, sum:integer;
begin
  write('Введите число: ');
  read(k);
  for i:=1 to k do read(a[i]);
  for i:=1 to k do
    if a[i] mod 10 = 5 then
      sum:=sum + a[i];
 
  write('Сумма равна: ', sum);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с написанием легкой программы на Паскале. Вот возможный вариант решения вашей задачи:

```pascal program SumOfFives; var n, i, x, sum: integer; begin readln(n); // считываем количество чисел в последовательности sum := 0; // инициализируем сумму нулем for i := 1 to n do // цикл по числам в последовательности begin readln(x); // считываем очередное число if x mod 10 = 5 then // если оно оканчивается на 5 sum := sum + x; // добавляем его к сумме end; writeln(sum); // выводим сумму end. ```

Эта программа работает следующим образом: сначала она считывает количество чисел в последовательности, затем инициализирует переменную sum нулем. Далее она запускает цикл по числам в последовательности, считывая каждое из них и проверяя, оканчивается ли оно на 5. Если да, то она прибавляет его к sum. После окончания цикла она выводит sum на экран.

Например, если ввести входные данные, которые вы привели:

``` 3 15 25 24 ```

то программа выведет:

``` 40 ```

Это потому, что только два числа в последовательности (15 и 25) оканчиваются на 5, и их сумма равна 40.

Надеюсь, это поможет вам. Если у вас есть еще вопросы, я рад помочь.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Паскале, которая решает задачу определения суммы чисел, оканчивающихся на 5, в последовательности натуральных чисел:

```pascal program SumOfNumbersEndingIn5;

var n, i, number, sum: integer;

begin sum := 0;

// Ввод количества чисел в последовательности write('Введите количество чисел в последовательности: '); readln(n);

// Ввод чисел и подсчет суммы чисел, оканчивающихся на 5 writeln('Введите числа:'); for i := 1 to n do begin readln(number); if number mod 10 = 5 then sum := sum + number; end;

// Вывод суммы чисел, оканчивающихся на 5 writeln('Сумма чисел, оканчивающихся на 5: ', sum); end. ```

Программа начинается с объявления переменных `n`, `i`, `number` и `sum`. Переменная `n` будет содержать количество чисел в последовательности, `i` используется для итерации по числам, `number` хранит текущее введенное число, а `sum` будет содержать сумму чисел, оканчивающихся на 5.

Затем программа запрашивает у пользователя количество чисел в последовательности и считывает это значение в переменную `n`.

Далее программа запрашивает у пользователя числа в последовательности и проверяет, оканчивается ли каждое число на 5. Если число оканчивается на 5, то оно добавляется к переменной `sum`.

После ввода всех чисел программа выводит сумму чисел, оканчивающихся на 5.

Пример входных данных: ``` 3 15 25 24 ```

Пример выходных данных: ``` Сумма чисел, оканчивающихся на 5

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос