Составить программу, формирующую массив из 10 дробных чисел вводом с клавиатуры (см. пример) и
находящую сумму всех его элементов. Ответ написать как пишут в паскале.Ответы на вопрос
uses crt;
var
mas: array[1..10] of real;
sum: real;
i: integer;
Begin
sum:=0;
for i:=1 to 10 do
Begin
write('mas', i, ' = ');
readln(mas[i]);
sum:=sum + mas[i];
end;
writeln();
writeln('sum = ' , sum);
readln;
end.
Программа, которая формирует массив из 10 дробных чисел, вводимых с клавиатуры, и находит сумму всех его элементов, может быть написана на языке Паскаль следующим образом:
``` program SumOfArrayElements;
const SIZE = 10;
var arr: array[1..SIZE] of Real; i: Integer; sum: Real;
begin sum := 0;
writeln('Введите ', SIZE, ' дробных чисел: ');
for i := 1 to SIZE do begin write('Число ', i, ': '); readln(arr[i]); sum := sum + arr[i]; end;
writeln('Сумма всех элементов массива: ', sum);
end. ```
Эта программа начинается с объявления константы `SIZE`, которая определяет размер массива. Затем объявляется массив `arr` типа `Real`, в котором будут храниться введенные дробные числа, а также переменные `i` для цикла и `sum` для хранения суммы элементов массива.
Далее, программа выводит приглашение к вводу и считывает 10 дробных чисел с клавиатуры в цикле `for`. Каждое число добавляется к переменной `sum`, чтобы найти общую сумму всех элементов массива.
Наконец, программа выводит результат - сумму всех элементов массива.
Теперь вы можете использовать эту программу на Паскале, чтобы ввести 10 дробных чисел и найти их сумму.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
