Вопрос задан 13.01.2020 в 23:55. Предмет Информатика. Спрашивает Нестеренко Илья.

Составить программу, которая подсчитывает количество палиндромов среди натуральных четырехзначных

чисел. Pascal
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнов Евгений.
Var
i, k: integer;
begin
k:=0;
for i:=1000 to 9999 do
if (i div 1000 = i mod 10) and (i div 100 mod 10 = i mod 100 div 10) then
inc(k);
writeln(k);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для подсчета палиндромов среди натуральных четырехзначных чисел

Для подсчета количества палиндромов среди натуральных четырехзначных чисел в PascalABC можно использовать следующую программу:

```pascal program CountPalindromes;

var number, reverse, count: integer;

begin count := 0;

for number := 1000 to 9999 do begin reverse := 0; var temp := number;

while temp > 0 do begin reverse := reverse * 10 + temp mod 10; temp := temp div 10; end;

if number = reverse then count := count + 1; end;

writeln('Количество палиндромов среди натуральных четырехзначных чисел: ', count); end. ```

Эта программа использует цикл `for` для перебора всех натуральных четырехзначных чисел от 1000 до 9999. Для каждого числа она проверяет, является ли оно палиндромом, сравнивая его с обратным числом. Если число равно обратному числу, то оно считается палиндромом, и счетчик увеличивается на 1.

В конце программы выводится количество найденных палиндромов.

Примечание: Эта программа написана на языке PascalABC. Убедитесь, что у вас установлена среда разработки PascalABC.NET для компиляции и запуска этой программы.

Источник:

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос