
Составить программу паскаль, которая выводит на экран олимпийские кольца. Срочно, заранее большое
спасибо)

Ответы на вопрос

var
gd, gm, xc, yc, r, x, y: integer;
begin
clrscr;
repeat
writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
readln(xc, yc);
until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
gd := 0;
initgraph(gd, gm, '');
setbkcolor(15);
cleardevice;
r := 50;
setlinestyle(0, 0, 3);
setcolor(9);
circle(xc, yc, r);
setcolor(8);{темно-серый, черный не нарисовать}
circle(xc + 2 * r, yc, r);
setcolor(12);
circle(xc + 4 * r, yc, r);
setcolor(14);
circle(xc + r, yc + r, r);
setcolor(10);
circle(xc + 3 * r, yc + r, r);
readln
end.



Программа на языке Паскаль для вывода олимпийских колец на экран может выглядеть следующим образом:
``` program OlympicRings;
uses crt;
procedure DrawOlympicRings; begin // Отрисовка колец TextColor(White); // Красное кольцо gotoxy(10, 10); write('O'); // Зеленое кольцо TextColor(Green); gotoxy(14, 10); write('O'); // Синее кольцо TextColor(Blue); gotoxy(18, 10); write('O'); // Желтое кольцо TextColor(Yellow); gotoxy(12, 12); write('O'); // Черное кольцо TextColor(Black); gotoxy(16, 12); write('O'); end;
begin // Очистка экрана clrscr; // Вывод олимпийских колец DrawOlympicRings; // Ожидание нажатия клавиши для завершения программы readkey; end. ```
Программа использует модуль `crt` для работы с цветами текста и функцию `gotoxy` для позиционирования курсора в нужное место на экране. Она определяет процедуру `DrawOlympicRings`, которая отрисовывает каждое кольцо по отдельности, устанавливая нужный цвет текста перед выводом символа 'O'. В основной части программы вызывается процедура `DrawOlympicRings`, а затем программа ожидает нажатия клавиши для завершения.
После компиляции и запуска этой программы на экране должны быть выведены олимпийские кольца.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili