Составить программу в Паскале и блок схему: Вычисление суммы ряда S=1-1/2+1/4-1/6+...1/N.
Ответы на вопрос
var n,i,l,m:integer; sum:real;
begin
readln(n);
sum:=1; l:=1;
while m<>n do begin
m:=m+2;
sum:=sum-((1/m)*l);
l:=l*-1;
end;
writeln(sum);
end.
Программа на языке Паскаль для вычисления суммы ряда S=1-1/2+1/4-1/6+...1/N:
``` program SumOfSeries; var N, i: integer; S: real; begin writeln('Введите число N:'); readln(N); S := 1; // инициализация суммы for i := 2 to N do begin if i mod 2 = 0 then // проверка на четность S := S + 1/i else S := S - 1/i; end; writeln('Сумма ряда S = ', S); end. ```
Блок-схема для данной программы:
``` +------------------+ | Ввод N | +------------------+ | v +------------------+ | Инициализация S | +------------------+ | v +------------------+ | i = 2 | +------------------+ | v +------------------+ | i > N? | +------------------+ | | no yes | | v | +------------------+ | i mod 2 = 0? | +------------------+ | | no yes | | v | +------------------+ | S = S
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
