 
Составьте программу для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7
одновременно. С помощью цикла for на Паскале 0
        0
         0
        0
    Ответы на вопрос
 
        var s: real;
i,n: integer;
begin
s:=0;
n:=0;
for i:=250 to 500 do begin
if (i mod 5=0) and (i mod 7=0) then begin s:=s+i; n:=n+1;
end;
end;
s:=s/n;
writeln(s);
end.
 0
                    0
                     0
                    0
                 
        Вот программа, написанная на паскале.
Комментарий: sum - общая сумма всех чисел, делящихся на 5 и на 7 одновременно, count - их количество.
Ответ: 385
 0
                    0
                     0
                    0
                 
            Я могу помочь вам с написанием программы на Паскале для вычисления среднего арифметического чисел от 250 до 500, кратных 5 и 7 одновременно. Вот примерный алгоритм решения задачи:
- Объявить переменные для суммы, количества и среднего арифметического чисел. - Присвоить им начальные значения нуля. - С помощью цикла for перебрать все числа от 250 до 500 с шагом 5. - Для каждого числа проверить, делится ли оно на 7 без остатка. - Если да, то добавить его к сумме и увеличить количество на единицу. - После окончания цикла вычислить среднее арифметическое как отношение суммы к количеству. - Вывести результат на экран.
Вот возможный код программы на Паскале:
```pascal program Average; var sum, count, average, i: integer; begin sum := 0; // сумма чисел count := 0; // количество чисел for i := 250 to 500 do // цикл от 250 до 500 с шагом 5 if i mod 7 = 0 then // если число делится на 7 без остатка begin sum := sum + i; // добавить его к сумме count := count + 1; // увеличить количество на единицу end; average := sum div count; // вычислить среднее арифметическое writeln('Среднее арифметическое чисел от 250 до 500, кратных 5 и 7, равно ', average); // вывести результат end. ```
Надеюсь, это поможет вам.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			