Составить программу которая проверяет или равные 3 введенные числа и выводит на экране
соответствующее сообщение (равные или неравные)Ответы на вопрос
program zadacha;
var
a,b,c:integer;
begin
read(a,b,c);
if (a=b)and(b=c) then
write('Равны')
else
write('Не равны')
end.
Для создания программы, которая проверяет, равны ли три введенных числа, и выводит соответствующее сообщение на экран, можно использовать следующий код на языке программирования C++:
```cpp
#include
int main() { int num1, num2, num3;
std::cout << "Введите первое число: "; std::cin >> num1;
std::cout << "Введите второе число: "; std::cin >> num2;
std::cout << "Введите третье число: "; std::cin >> num3;
if (num1 == num2 && num2 == num3) { std::cout << "Все три числа равны." << std::endl; } else { std::cout << "Числа не равны." << std::endl; }
return 0; } ```
В этой программе мы сначала объявляем три переменные `num1`, `num2` и `num3`, которые будут хранить введенные числа. Затем мы запрашиваем у пользователя ввод трех чисел с помощью функции `std::cin`. После этого мы сравниваем значения переменных с помощью оператора `==`. Если все три числа равны, то выводим сообщение "Все три числа равны". В противном случае выводим сообщение "Числа не равны".
Примечание: Данный код предполагает, что пользователь будет вводить целые числа. Если требуется работать с числами других типов (например, числами с плавающей запятой), то необходимо изменить тип переменных и использовать соответствующие операторы сравнения.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
