PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры.
Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.Ответы на вопрос
a,b,i : integer;
begin
readln (a,b);
for i := (a+1) to (b-1) do
if i mod 2 = 0 then
writeln (i);
end.
вроде работает pascalABC.Net
Программа на языке PascalABC для вывода четных чисел в заданном интервале
```pascal program EvenNumbers;
var num1, num2, i: integer;
begin writeln('Введите два целых числа:'); readln(num1, num2);
if num1 = num2 then begin writeln('Введенные числа равны. Программа не будет выводить четные числа.'); end else if num2 < num1 then begin writeln('Второе число меньше первого. Программа не будет выводить четные числа.'); end else begin writeln('Четные числа в интервале между ', num1, ' и ', num2, ':'); for i := num1 + 1 to num2 - 1 do begin if i mod 2 = 0 then begin write(i, ' '); end; end; writeln; end;
readln; end. ```
Программа начинается с объявления переменных `num1`, `num2` и `i`, которые будут использоваться для хранения введенных чисел и для итерации по интервалу. Затем программа запрашивает у пользователя ввод двух целых чисел с помощью `readln`.
Далее, программа проверяет несколько условий: - Если `num1` и `num2` равны, то выводится сообщение о том, что введенные числа равны, и программа не будет выводить четные числа. - Если `num2` меньше `num1`, то выводится сообщение о том, что второе число меньше первого, и программа не будет выводить четные числа.
Если ни одно из этих условий не выполняется, то программа переходит к выводу четных чисел в интервале между `num1` и `num2`. В цикле `for` программа проверяет каждое число в интервале от `num1 + 1` до `num2 - 1`. Если число делится на 2 без остатка (`i mod 2 = 0`), то оно является четным числом и выводится на экран с помощью `write`.
Программа завершается после нажатия клавиши Enter с помощью `readln`.
Пример работы программы:
``` Введите два целых числа: 10 20 Четные числа в интервале между 10 и 20: 12 14 16 18 ```
``` Введите два целых числа: -8 -3 Четные числа в интервале между -8 и -3: -6 -4 ```
``` Введите два целых числа: 6 8 ```
В этом случае программа не выводит никаких чисел, так как интервал между 6 и 8 не содержит четных чисел.
``` Введите два целых числа: 5 5 Введенные числа равны. Программа не будет выводить четные числа. ```
``` Введите два целых числа: 8 6 Второе число меньше первого. Программа не будет выводить четные числа. ```
Примечание: Программа написана на языке PascalABC. Если вы используете другую среду разработки, убедитесь, что она поддерживает этот язык или адаптируйте код для своей среды.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
