Вопрос задан 11.01.2020 в 04:06. Предмет Информатика. Спрашивает Захаров Коля.

Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных

данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве. На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива. Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Устименко Владислав.
Var
  i, n: integer;
  a: array[1..1000]of integer;
 begin
  readln(n);
  for i := 1 to n do read(a[i]);
  writeln;
  for i := 1 to n do if (a[i] >= 0) then write(a[i], ' ');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно использовать следующий алгоритм:

1. Считываем число n - количество элементов в массиве. 2. Считываем массив a из n элементов. 3. Создаем пустой массив result. 4. Проходим по каждому элементу ai в массиве a. - Если ai >= 0, добавляем ai в массив result. 5. Выводим все элементы массива result через пробел.

Пример решения на языке Python:

```python n = int(input()) # Считываем количество элементов в массиве a = list(map(int, input().split())) # Считываем массив

result = [] # Пустой массив для хранения неотрицательных чисел

for ai in a: if ai >=

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос