
Напишите программу, которая получает число из данного файла, делит его на 3 и записывает ответ в
другой файл

Ответы на вопрос

Программа на языке Pascal. Программа получает число из файла input.txt и записывает результат в файл output.txt
var a: real;
f: text;
begin
assign(f,'input.txt');
reset(f);
read(f,a);
close(f);
assign(f,'output.txt');
rewrite(f);
write(f,a/3);
close(f);
end.



===== PascalABC.NET =====
begin
WriteAllText('File2.txt',
(integer.Parse(ReadAllText('File1.txt')) div 3).ToString)
end.
Объяснение:
Текстовый файл File1.txt содержит запись целого числа.
ReadAllText('File1.txt') считывает сдержимое файла в символьную строку,
integer.Parse( ) выделяет из нее целое целое число, div 3 выполняет деление на 3, результат при помощи ToString преобразуется к строке, на основе которой WriteAllText('File2.txt'( ) создает текстовый файл File2.txt.
Файлы должны находиться в той же папке, что и исходный текст программы, либо надо в именах явно указывать полный путь.



Конечно, вот пример программы на Python, который считывает число из одного файла, делит его на 3 и записывает результат в другой файл:
```python # Открываем файл с числом для чтения with open('input.txt', 'r') as file: number = int(file.read().strip()) # Считываем число из файла и конвертируем в целое число
# Выполняем деление на 3 result = number / 3
# Открываем файл для записи результата with open('output.txt', 'w') as file: file.write(str(result)) # Записываем результат в файл (преобразуем в строку, если нужно) ```
Этот скрипт предполагает, что у вас есть файл с именем "input.txt", содержащий число, которое нужно поделить на 3, и после деления результат будет записан в файл "output.txt".
Когда вы выполните этот код, он прочтет число из "input.txt", поделит его на 3 и запишет результат в "output.txt".
Если файлы отсутствуют или путь к ним указан неверно, код может вызвать ошибку. Убедитесь, что файл "input.txt" существует и содержит числовое значение.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili