Написать программу на языке C/C++, которая принимает на вход: 1. N целочисленных элементов, где N =
5 + (k mod 5). Здесь k=10. N можно задавать равным конкретному числу прямо внутри программы. 2. Целое число A (после того, как считали N чисел). Найдите индекс (порядковый номер) первого числа (из введенных N чисел), равного A. Если такого числа нет, выведите соотв. сообщение (например, “no number A”). Написать данную программу с использованием конструкции if, цикла for, ИСПОЛЬЗУЙТЕ массив. Использование команды goto запрещено. Подсказка: заведите целочисленный массив, соответствующий вашему варианту задания (т.е числу N), например, int SavedNumbers[7]; в цикле считывайте очередное целое число, пишите его в массив. После считки всех чисел и окончания цикла считайте число A. Ещё раз пройдите по массиву и найдите первое вхождение A, если оно есть.Ответы на вопрос
        int main() {
const int k = 10;
int n = 5 + k % 5;
int savedNumbers[n];
for (int i = 0; i < n; i++) {
scanf("%d", &savedNumbers[i]);
}
int a;
scanf("%d", &a);
for (int i = 0; i < n; i++) {
if (a == savedNumbers[i]) {
printf("First in - %d.", i + 1);
return 0;
}
}
printf("No number A.");
return 0;
}
            Вот пример программы на языке C++, которая выполняет указанную задачу:
```cpp
#include 
int main() { const int N = 5; // Задаем значение N int SavedNumbers[N]; // Создаем массив для сохранения чисел
// Считываем N целочисленных элементов и сохраняем их в массив for (int i = 0; i < N; i++) { std::cout << "Введите число #" << i + 1 << ": "; std::cin >> SavedNumbers[i]; }
int A; std::cout << "Введите число A: "; std::cin >> A;
// Ищем первое вхождение числа A в массиве int index = -1; for (int i = 0; i < N; i++) { if (SavedNumbers[i] == A) { index = i; break; } }
// Выводим результат if (index != -1) { std::cout << "Индекс первого числа равного A: " << index << std::endl; } else { std::cout << "Нет числа равного A" << std::endl; }
return 0; } ```
В этой программе мы сначала задаем значение N равным 5. Затем создаем массив `SavedNumbers` размером N для сохранения введенных чисел. Затем мы считываем N целочисленных элементов с помощью цикла `for` и сохраняем их в массив.
После этого мы считываем число A с помощью `std::cin`. Затем мы проходим по массиву и ищем первое вхождение числа A. Если такое число найдено, мы сохраняем его индекс в переменной `index`. Если число не найдено, `index` остается равным -1.
Наконец, мы выводим результат. Если `index` не равен -1, мы выводим сообщение с индексом первого числа равного A. В противном случае, мы выводим сообщение о том, что такого числа нет.
Примечание: В данной программе предполагается, что пользователь будет вводить ровно N целочисленных элементов и число A. Если пользователь вводит некорректные данные (например, не числа), программа может работать некорректно или завершиться с ошибкой. В реальных программных проектах рекомендуется добавить проверку на корректность ввода данных.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			