Вопрос задан 26.05.2018 в 07:37. Предмет Информатика. Спрашивает Кравченко Юра.

ПОЖАЛУЙСТА, ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ Напишите программу для решения следующей задачи. На

зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Антончик Саша.

Var
 n,b,i,k,r:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(b);
   if b>=8 then
     begin
     k:=k+1;
     r:=r+b;
    end;
  end;
 writeln('Количество сдавших:',k);
 writeln('Среднее значение:',r/k);
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос