Вопрос задан 06.07.2019 в 17:13.
Предмет Информатика.
Спрашивает Копейкин Артём.
Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее
арифметическое этих чиселОтветы на вопрос
Отвечает Голубева Мария.
Var a,n,sum: integer;
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
