Вопрос задан 30.06.2019 в 13:24.
Предмет Информатика.
Спрашивает Майоров Ярослав.
Я каждой задачи составить программу содержащую ветвления и определяющую, принадлежит ли точка с
координатами (X, Y) заштрихованной области. НУЖНО ТОЛЬКО 16!
Ответы на вопрос
Отвечает Пузина Дарья.
Можно составить уравнение окружности, посчитав радиус: x^2 + y^2 = 36 (6^2). И если сумма слева будет меньше или равна 36, то точка будет лежать внутри круга. Но у нас ещё первая четверть не закрашена. В таком случае либо x <= 0 (а y может иметь любой знак), либо наоборот.
Итак, решение (на Паскале):
var
x, y: real;
begin
writeln('Введите координаты точки x и y соответственно:');
readln(x, y);
if (x <= 0) or (y <= 0) then
if x * x + y * y <= 36 then
writeln('Принадлежит')
else
writeln('Не принадлежит')
else
writeln('Не принадлежит')
end.
Итак, решение (на Паскале):
var
x, y: real;
begin
writeln('Введите координаты точки x и y соответственно:');
readln(x, y);
if (x <= 0) or (y <= 0) then
if x * x + y * y <= 36 then
writeln('Принадлежит')
else
writeln('Не принадлежит')
else
writeln('Не принадлежит')
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
