Вопрос задан 28.06.2019 в 13:06. Предмет Информатика. Спрашивает Багдасарова Рузана.

Напишите программу на языке Паскаль!!! На экран вводится два пятизначных числа. Найти среднее

арифметическое всех четных цифр в наименьшем числе.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хамутовская Кристина.
Var
  a, b, n: integer;
  sr: real;
 
begin
  sr := 0;
  n := 0;
  read(a, b);
  if(a > b) then a := b;
  while a > 0 do
   begin
    if((a mod 10) mod 2 = 0) then begin
      sr := sr + a mod 10;
      n := n + 1;
    end;
    a := a div 10;
  end;
  write(sr / n);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос