Вопрос задан 26.06.2019 в 07:49.
Предмет Информатика.
Спрашивает Габрукович Екатерина.
Задан массив Y с количеством элементов N. Сформируйте массив, в котором элементы с четными
индексами будут равны соответствующим элементам исходного массива, а элементы с нечетными индексами будут равны 0. помогите очень надо. написать программу на языке паскаль*(Ответы на вопрос
Отвечает Горянина Вероника.
Const n=10;
var y,z:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
y[i]:=random(51);
write(y[i]:4);
end;
writeln;
writeln('Полученный массив:');
for i:=1 to n do
if i mod 2 = 0 then z[i]:=y[i] else z[i]:=0;
for i:=1 to n do write(z[i]:4);
writeln;
end.
Пример:
Исходный массив:
16 22 48 16 9 33 27 42 40 24
Полученный массив:
0 22 0 16 0 33 0 42 0 24
var y,z:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
y[i]:=random(51);
write(y[i]:4);
end;
writeln;
writeln('Полученный массив:');
for i:=1 to n do
if i mod 2 = 0 then z[i]:=y[i] else z[i]:=0;
for i:=1 to n do write(z[i]:4);
writeln;
end.
Пример:
Исходный массив:
16 22 48 16 9 33 27 42 40 24
Полученный массив:
0 22 0 16 0 33 0 42 0 24
Отвечает Галстян Арсен.
//Индексация с 0
//Pascal ABC.NET 3.1 сборка 1256
Const n=10;
Var
i:integer;
ar2:array[0..n-1] of integer;
begin
var ar:=ArrRandomInteger(n,-10,10);
writeln('Array Y:');
ar.Println;
for i:=0 to n-1 do
ar2[i]:=0;
for i:=0 to n-1 do
if not(odd(i)) then ar2[i]:=ar[i];
writeln('Final array:');
ar2.Println;
end.
//Pascal ABC.NET 3.1 сборка 1256
Const n=10;
Var
i:integer;
ar2:array[0..n-1] of integer;
begin
var ar:=ArrRandomInteger(n,-10,10);
writeln('Array Y:');
ar.Println;
for i:=0 to n-1 do
ar2[i]:=0;
for i:=0 to n-1 do
if not(odd(i)) then ar2[i]:=ar[i];
writeln('Final array:');
ar2.Println;
end.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
