Вопрос задан 25.06.2019 в 00:43.
Предмет Информатика.
Спрашивает Антонов Антон.
Написать программу, которая проверяет, является ли введенная с клавиатуры строка целым числом
Ответы на вопрос
Отвечает Старостина Алена.
VAR
s: String;
i: LongInt;
BEGIN
Read(s);
for i := 1 to Length(s) do
if not((Ord(s[i]) > 47)and(Ord(s[i]) < 58)) then begin
Write(s,' - не является целым число'); Exit;
end;
Write(s,' - целое число');
END.
s: String;
i: LongInt;
BEGIN
Read(s);
for i := 1 to Length(s) do
if not((Ord(s[i]) > 47)and(Ord(s[i]) < 58)) then begin
Write(s,' - не является целым число'); Exit;
end;
Write(s,' - целое число');
END.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
