Вопрос задан 23.05.2018 в 17:09.
Предмет Информатика.
Спрашивает Куглер Полина.
ПОМОГИТЕ СДЕЛАТЬ ! Напишите программу,которая в последовательности целых чисел определяет
количество четных чисел кратных 3.Программа получает на выход целые числа .количество введенных чисел неизвестно ,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность ).Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: количество четных чисел,кратных 3 ПОМОГИТЕ СДЕЛАТЬ ??Ответы на вопрос
Отвечает Инкина Маргарита.
Program a1;
var c,k,a: integer;
begin
a:=1;
while (a<>0) and (c<2) do
begin
read(a);
if (ABS(a)<30000) and (a<>0) then
if ((a mod 2) = 0) and ((a mod 3)=0) then inc(k);
inc(c);
end;
writeln('kol = ',k);
end
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
