Вопрос задан 16.06.2019 в 23:22.
Предмет Информатика.
Спрашивает Кустов Марк.
Написать программу которая для заданного натурального числа n вычисляет сумму
1+1/1+2+1/1+2+3+···+1/1+2+···n в паскале .Ответы на вопрос
Отвечает Любишина Олеся.
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
readln(n);
s:=0;s1:=0;
for i:=1 to n do begin
s1:=s1+i;
s:=s+1/s1;
end;
writeln (s);
end.
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
readln(n);
s:=0;s1:=0;
for i:=1 to n do begin
s1:=s1+i;
s:=s+1/s1;
end;
writeln (s);
end.
Отвечает Сергеева Ангелина.
Var s: real; n,sn,i: integer;begin write('n = '); readln(n); s:=0; sn:=0; for i:=1 to n do begin sn:=sn+i; s:=s+1/(sn); writeln(s); end; writeln('сумма ряда: ',s);end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
