Вопрос задан 16.06.2019 в 12:21.
Предмет Информатика.
Спрашивает Бирюков Ярик.
Ребус Написать программу для решения арифметического ребуса Я + ОН + ОН + ОН + ОН + ОН + ОН + ОН +
ОН = МЫ где различные буквы надо заменить на различные цифры. Вывести количество различных решений для этого ребуса.Ответы на вопрос
Отвечает Куликов Артем.
Во первых, прежде чем мы напишем программу, обратим внимание на тот факт, что БУКВА О равна 1, что существенно уменьшит количество переборов в цикле. Запишем это выражение в виде:
A+8*(10+N)=(10*M+Y)
У нас получилось 4 вложенных цикла:
uses Crt;
var A, N, M, Y: integer;
begin
ClrScr;
for A:=0 to 9 do
for N:=0 to 9 do
if (A<>N) then
for M:=1 to 9 do
if (A<>M) and (N<>M) then
for Y :=0 to 9 do
if (A<>Y) and (N<>Y) and (M<>Y) then
if (A+8*(10+N)=10*M+Y) then
begin
Write('Я=', A,' ');
Write('O=', 1,' ');
Write('Н=', N,' ');
Write('M=', M,' ');
Write('Ы=', Y,' ');
WriteLn;
end;
ReadLn;
end.
И всего 8 различных ответов!!!
A+8*(10+N)=(10*M+Y)
У нас получилось 4 вложенных цикла:
uses Crt;
var A, N, M, Y: integer;
begin
ClrScr;
for A:=0 to 9 do
for N:=0 to 9 do
if (A<>N) then
for M:=1 to 9 do
if (A<>M) and (N<>M) then
for Y :=0 to 9 do
if (A<>Y) and (N<>Y) and (M<>Y) then
if (A+8*(10+N)=10*M+Y) then
begin
Write('Я=', A,' ');
Write('O=', 1,' ');
Write('Н=', N,' ');
Write('M=', M,' ');
Write('Ы=', Y,' ');
WriteLn;
end;
ReadLn;
end.
И всего 8 различных ответов!!!
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 11
Информатика 47
Информатика 32
Информатика 11
Информатика 258
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
