Вопрос задан 08.06.2019 в 23:46.
Предмет Информатика.
Спрашивает Андрющенко Руслан.
Напишите программу для решения следующей задачи.Девятиклассники участвовали в викторине по
математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. Пример работы программы:Входные данные 4 15 12 0 17 Выходные данные 17 YESОтветы на вопрос
Отвечает Реготов Даня.
Var
i, k,n, max: integer;
f:boolean;
begin
readln(k);
for i := 1 to k do
begin
readln(n);
if (i = 1) or (max < n) then
max := n;
f:=f or (n=0);
end;
writeln(max,' ', f);
end.
i, k,n, max: integer;
f:boolean;
begin
readln(k);
for i := 1 to k do
begin
readln(n);
if (i = 1) or (max < n) then
max := n;
f:=f or (n=0);
end;
writeln(max,' ', f);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
