Вопрос задан 07.06.2019 в 18:12.
Предмет Информатика.
Спрашивает Чемеков Даниил.
Программа запускается, но ввожу значения переменных, а ответ не выдаёт. Не могу понять, в чём
проблема? Занимаюсь недавно, не ругайте))И правильно ли я её вообще решила? var max,x,y,z,t:real; begin readln(x,y,z); if(x>y)then max:=x else max:=y; if(z>max)then max:=z; if(z*max t:=x*x+y*y+z*z-2*sqr(max); if(t>0)then writeln('acute'); if(t=0)then writeln('right'); if(t<0)then writeln('obtuse') else writeln('impossible'); end; readln; end. Сама задача, если понадобится Определите тип треугольника (остроугольный, тупоугольный, прямоугольный) с данными сторонами. Входные данные Даны три натуральных числа – стороны треугольника. Выходные данные Необходимо вывести одно из слов: right для прямоугольного треугольника, acute для остроугольного треугольника, obtuse для тупоугольного треугольника или impossible, если входные числа не образуют треугольника.Ответы на вопрос
Отвечает Смирнов Евгений.
Программа должна выглядеть так
var
max,x,y,z,t:real;
begin
readln(x,y,z);
if(x>y)then max:=x
else max:=y;
if(z>max)then max:=z;
if(z*max*t=x*x+y*y+z*z-2*sqr(max)) then begin
if(t>0)then writeln('acute');
if(t=0)then writeln('right');
if(t<0)then writeln('obtuse')
end
else writeln('impossible');
readln;
end.
var
max,x,y,z,t:real;
begin
readln(x,y,z);
if(x>y)then max:=x
else max:=y;
if(z>max)then max:=z;
if(z*max*t=x*x+y*y+z*z-2*sqr(max)) then begin
if(t>0)then writeln('acute');
if(t=0)then writeln('right');
if(t<0)then writeln('obtuse')
end
else writeln('impossible');
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
