Вопрос задан 21.05.2019 в 08:52. Предмет Информатика. Спрашивает Гвоздев Артем.

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше. Нахождение

количество цифр числа оформить в виде функцииРешение на паскале, написать программу
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иванов Витя.
function len(a: integer): byte;
begin
  result := Length(IntToStr(a));
end;

var
  a, b: integer;

begin
  for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее
  begin
    readln(a);
    if (len(a) > len(b)) then
      b := a;
  end;
  writeln(b);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос