Вопрос задан 19.05.2019 в 06:13.
Предмет Информатика.
Спрашивает Гашишев Дмитрий.
Составьте программу вывода числа делителей натурального числа М В ПАСКАЛЕ ABC ПОЖАЛУЙСТА
Ответы на вопрос
        Отвечает Штокибас Дробиус.
                
     Var m,d,kol:uint64;
begin
read(m);
for d:=1 to m do begin
if (m mod d)=0 then inc(kol);
end;
write(kol);
end. Это программа для делителей от 1 до m.
var m,d,kol:uint64;beginread(m);for d:=2 to m-1 do begin if (m mod d)=0 then inc(kol); end;write(kol);end. Эта программа для делителей от 2 до m-1.
                                        begin
read(m);
for d:=1 to m do begin
if (m mod d)=0 then inc(kol);
end;
write(kol);
end. Это программа для делителей от 1 до m.
var m,d,kol:uint64;beginread(m);for d:=2 to m-1 do begin if (m mod d)=0 then inc(kol); end;write(kol);end. Эта программа для делителей от 2 до m-1.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			