Вопрос задан 13.05.2019 в 16:56.
Предмет Информатика.
Спрашивает Гордий Дима.
Кто понимает Паскаль, обращаюсь к вам! Очень нужна ваша помощь! Составьте программу, которая
выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.Ответы на вопрос
Отвечает Данилова Валерия.
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var p:=Pos('...',s);
if p>0 then Writeln(Copy(s,1,p-1))
end.
Пример
> Это такая... тестовая... строка
Это такая
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
Writeln(s.Replace('...','.').Replace(' ','.'))
end.
Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var p:=Pos('...',s);
if p>0 then Writeln(Copy(s,1,p-1))
end.
Пример
> Это такая... тестовая... строка
Это такая
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
Writeln(s.Replace('...','.').Replace(' ','.'))
end.
Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
