написать программу на паскале:определить количество строк матрицы, в которых хотя бы один элемент
равен tОтветы на вопрос
Program Natasha1925_2;
uses crt;
const n=50;
var
a:array[1..n,1..n] of integer;
t:integer;
i,j,kwo:integer;
yes:boolean;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
writeln();
randomize;
{создание массива}
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(101)-50;
write(a[i,j]:7:2);
end;
writeln();
end;
write('Введите число t: '); read(t);
{поиск строк}
kwo:=0;
for i:=1 to n do
begin
yes:=FALSE;
for j:=1 to n do
if a[i,j]=t then
yes:=TRUE;
if yes then kwo:=kwo+1;
end;
writeln('Количество строк: ',kwo);
end.
uses crt;
var
a:array [1..100,1..100] of real;
t:real; i,j,k:integer;
begin
randomize;
write('Введите количество строк матрицы: '); read(i);
write('Введите количество столбцов матрицы: '); read(j);
write('Введите число t: '); read(t);
clrscr;
for i:=1 to i do
begin
for j:=1 to j do
begin
a[i,j]:=random(100)-50;
write(a[i,j],' ');
end;
writeln;
end;
k:=0;
for i:= 1 to i do
begin
for j:= 1 to j do
begin
if a[i,j]=t then
begin
k:=k+1;
j:=1;
i:=i+1;
end;
end;
end;
writeln('Количество строк: ',k);
end.
Для решения данной задачи на определение количества строк матрицы, в которых хотя бы один элемент равен "t", можно написать программу на языке Pascal. Вот пример такой программы:
```pascal program CountRowsWithT;
const N = 3; // количество строк матрицы M = 4; // количество столбцов матрицы
var matrix: array[1..N, 1..M] of char; // матрица i, j, count: integer; // переменные для циклов и подсчета строк
begin // Ввод матрицы writeln('Введите элементы матрицы:'); for i := 1 to N do begin for j := 1 to M do begin read(matrix[i, j]); end; readln; // переход на следующую строку end;
// Подсчет строк с элементом "t" count := 0; for i := 1 to N do begin for j := 1 to M do begin if matrix[i, j] = 't' then begin count := count + 1; break; // если найден элемент "t", переходим к следующей строке end; end; end;
// Вывод результата writeln('Количество строк матрицы, в которых хотя бы один элемент равен "t": ', count);
readln; end. ```
В данной программе мы используем двумерный массив `matrix` для хранения элементов матрицы. Затем мы вводим элементы матрицы с помощью вложенных циклов `for`. Далее, мы проходим по каждой строке матрицы и проверяем, содержит ли она хотя бы один элемент равный "t". Если да, то увеличиваем счетчик `count`. В конце программы выводим количество строк, у которых найден элемент "t".
Примечание: В данном примере мы предполагаем, что размер матрицы уже известен и равен 3 строкам и 4 столбцам. Вы можете изменить значения констант `N` и `M` в соответствии с вашими потребностями.
Надеюсь, это поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, пожалуйста, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
