Написать программу которая формирует одномерный массив ( массив температур ) из n целых чисел и
выводит количество отрицательных элементов ( дней в месяце ).срочноPascal ABC срочно!Ответы на вопрос
var T: array [1..12] of real;
i:integer;
begin
{Цикл ввода}
for i:=1 to 12 do
begin
Write('Температура [',i:2,'] = ');
readln(T[i]);
end;
writeln();
{Поиск отрицательных элементов}
Writeln('Отрицательные температуры');
for i:=1 to 12 do
begin
if T[i]<=0 then
Writeln(T[i]);
end;
Readln();
end.
Конечно, вот программа на языке Pascal, которая решает вашу задачу:
```pascal program CountNegativeElements;
var temperatures: array of Integer; n, i, negativeCount: Integer;
begin Write('Введите количество температур: '); Readln(n); SetLength(temperatures, n); negativeCount := 0; for i := 0 to n - 1 do begin Write('Введите температуру ', i + 1, ': '); Readln(temperatures[i]); if temperatures[i] < 0 then negativeCount := negativeCount + 1; end; Write('Количество отрицательных температур: ', negativeCount); end. ```
В этой программе мы сначала запрашиваем у пользователя количество температур в массиве. Затем мы создаем массив с помощью функции `SetLength`, присваивая ему размер, равный введенному числу `n`.
Затем мы используем цикл `for` для заполнения массива `temperatures`. Внутри цикла мы запрашиваем у пользователя каждую температуру и проверяем, является ли она отрицательной. Если да, то мы увеличиваем значение переменной `negativeCount` на 1.
После завершения цикла мы выводим количество отрицательных температур на экран.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, пожалуйста, уточните.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
