
Нужно написать программу на языке С++ , которая добавляет N элементов, начиная с номера K.


Ответы на вопрос

using namespace std;
int main()
{
int n, k, sum = 0;
cout << "n = ";
cin >> n;
cout << "k = ";
cin >> k;
for (int i = 0; i < n; i++) {
sum += k;
k++;
}
cout << "Ответ: "
<< sum << endl;
}



Конечно, я могу помочь вам написать программу на языке C++, которая добавляет N элементов, начиная с номера K. Предположим, что у вас есть некоторый массив (или вектор), и вы хотите добавить N элементов, начиная с индекса K. Вот пример простой программы на C++:
```cpp
#include
int main() {
std::vector
// Заполняем вектор некоторыми начальными значениями for (int i = 0; i < 10; ++i) { myVector.push_back(i); }
// Выводим исходный вектор std::cout << "Исходный вектор: "; for (const auto& element : myVector) { std::cout << element << " "; } std::cout << std::endl;
// Введите значение N и K с клавиатуры int N, K; std::cout << "Введите количество элементов N: "; std::cin >> N; std::cout << "Введите индекс K, с которого начать добавление элементов: "; std::cin >> K;
// Проверка на корректность введенных данных if (K < 0 || K > myVector.size()) { std::cout << "Некорректный индекс K." << std::endl; return 1; }
// Добавляем N элементов, начиная с индекса K for (int i = 0; i < N; ++i) { myVector.insert(myVector.begin() + K + i, 0); // Вставляем элементы со значением 0 }
// Выводим измененный вектор std::cout << "Измененный вектор: "; for (const auto& element : myVector) { std::cout << element << " "; } std::cout << std::endl;
return 0; } ```
Эта программа создает вектор, заполняет его значениями от 0 до 9, затем запрашивает у пользователя значения N и K. После этого она вставляет N элементов со значением 0, начиная с индекса K, и выводит измененный вектор.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili