
ПЖ БЫРЕЕ ПЛИЗЗЗ 2. (дз) Программа получает на вход два числа и выводит текст задачи про ноги и
головы жуков и пауков. Например, если на вход программа получила числа 5 и 36, то она выдаст следующий текст: «В коробке сидели жуки и пауки. Всего у них было 5 голов и 36 ног. Сколько было жуков и сколько – пауков?» 6. (дз) Дано число. Программа пишет, делится ли оно на 11. 7. (дз) Дано двухзначное число. Написать его, если первая цифра больше второй, и его наоборот, если вторая цифра не больше второй.

Ответы на вопрос

begin;
readln(n);
readln(m);
writeln('В коробке сидели жуки и пауки. Всего у них было ',n,' голов и ',m,' ног. Сколько было жуков и сколько – пауков?');
end.
6. var n:integer;
begin;
readln(n);
if n mod 11=0 then writeln('Да') else writeln('Нет');
end.
7. var n1,n2,m:integer;
begin;
readln(m);
n1:=m mod 10;
m:=m div 10;
n2:=m mod 10;
if n2>n1 then write(n2*10+n1) else write(n1*10+n2);
end.



2. Программа получает на вход два числа и выводит текст задачи про ноги и головы жуков и пауков. Например, если на вход программа получила числа 5 и 36, то она выдаст следующий текст: «В коробке сидели жуки и пауки. Всего у них было 5 голов и 36 ног. Сколько было жуков и сколько – пауков?»
Для решения этой задачи можно использовать математическую систему уравнений. Пусть x - количество жуков, y - количество пауков. Тогда у нас есть два условия:
1) Количество голов равно количеству жуков плюс количество пауков: x + y = 5 2) Количество ног равно количеству жуков умноженному на 6 (так как у жуков 6 ног) плюс количество пауков умноженное на 8 (так как у пауков 8 ног): 6x + 8y = 36
Решая эту систему уравнений, мы можем определить количество жуков и пауков.
3. Дано число. Программа пишет, делится ли оно на 11.
Для проверки деления числа на 11 можно использовать операцию модуля (%). Если результат остатка от деления числа на 11 равен 0, то число делится на 11 без остатка.
4. Дано двухзначное число. Написать его, если первая цифра больше второй, и его наоборот, если вторая цифра не больше первой.
Для решения этой задачи можно использовать операторы условия. Нам нужно сравнить первую и вторую цифры числа. Если первая цифра больше второй, то выводим число без изменений. Если вторая цифра не больше первой, то меняем местами цифры числа и выводим его. Например, если дано число 54, то программа выведет 54, а если дано число 37, то программа выведет 73.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili