Вопрос задан 11.05.2019 в 05:21. Предмет Информатика. Спрашивает Капбарова Назым.

Составьте программу для следующей задачи.За год квартплата работников повышалась дважды. Первый раз

на 30%, а второй на 40%. Год назад семья Березовских платила квартплату 80 рублей в месяц. Выведите сумму, которую они платят сейчас. Необходимые исходные данные введите с клавиатуры. Ответ прикрепите в виде файла в среде PascalABC.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Zakharov Danila.
Если возникнут вопросы или ошибки в ходе работы программы, пиши в комментариях.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для решения задачи может выглядеть следующим образом:

```pascal program kvartplata; var kvartplata_1, kvartplata_2, kvartplata_now: Real; begin write('Введите текущую квартплату: '); readln(kvartplata_now); kvartplata_1 := kvartplata_now * 0.3; // первый раз повышение на 30% kvartplata_2 := kvartplata_1 * 0.4; // второй раз повышение на 40% kvartplata_now := kvartplata_now + kvartplata_1 + kvartplata_2; writeln('Сумма, которую платят Березовские сейчас: ', kvartplata_now:0:2, ' рублей'); end. ```

В этой программе мы считываем текущую квартплату с клавиатуры с помощью `readln`, затем вычисляем повышение на 30% (`kvartplata_1`) и повышение на 40% от первого повышения (`kvartplata_2`). Далее, к текущей квартплате добавляем оба повышения, чтобы получить итоговую сумму (`kvartplata_now`). Наконец, выводим результат с помощью `writeln`.

Основная идея программы заключается в использовании арифметических операций для вычисления суммы, а также в использовании переменных для хранения промежуточных результатов.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос