Вопрос задан 10.05.2019 в 04:35.
Предмет Информатика.
Спрашивает Перро Лера.
Написать программу чтобы паскаль вывел на экран числа 55555 4444 333 22
Ответы на вопрос
Отвечает Козловская Вика.
Var a,b,c:integer;
begin
c:=1;
for a:=5 downto 2 do begin
for b:=5 downto c do begin
write(a);
end;
writeln('');
c:=c+1;
end;
end.
begin
c:=1;
for a:=5 downto 2 do begin
for b:=5 downto c do begin
write(a);
end;
writeln('');
c:=c+1;
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, в Паскале можно написать программу, чтобы вывести такую последовательность чисел. Вот пример программы:
```pascal program OutputNumbers;
var i, j: integer;
begin for i := 5 downto 2 do begin for j := 1 to i do begin write(i); end; writeln(); end; end. ```
Эта программа использует два цикла `for`. Внешний цикл идет от 5 до 2, а внутренний цикл выводит число `i` нужное количество раз (от 5 до 2 раз) с новой строки после каждого числа. Если скомпилировать и запустить эту программу в среде разработки Pascal, она выведет следующий результат:
``` 55555 4444 333 22 ```
Это основная идея программы. Если у тебя возникнут вопросы или есть что-то еще, во что бы ты хотел погрузиться в мир программирования, обращайся!
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 43
Информатика 22
Информатика 42
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
