Нужна программа 1)Найти максимальный и минимальный элемент матрицы 2)найти сумму диагональных
элементов всё это в одной программе (паскаль)Ответы на вопрос
Var
a: Array[1..30,1..30] of Integer;
n,min, max, i,j,s: Integer;
BEGIN
writeln('n=');
readln(n);
Randomize;
Writeln('sluciayniy massiv:');
For i:=1 to n do
begin
For j:=1 to n do begin
a[i,j]:=Random(51)-25;
Write(a[i,j]:5);
end;
Writeln;
end;
s:=0;
min:= a[1,1];
max:= a[1,1];
for i:= 1 to n do
for j:= 1 to n do
if a[i,j]<min then
min := a[i,j];
for i:= 1 to n do
for j:= 1 to n do
if a[i,j]> max then
max:= a [i,j];
for i:=1 to n do
for j:= 1 to n do
if i=j then
s:= s+a[i,j];
writeln('min=',min, ' max=',max,' summa elementov glavnoi dioganali=',s);
readln;
end.
________________________________
Var
a: Array[1..100,1..100] of Integer;
n,min, max, i,j,s:Integer;
BEGIN
writeln('n=');
readln(n);
Writeln('vvedite massiv:');
For i:=1 to n do
begin
For j:=1 to n do
begin
read(a[i,j]);
end;
Writeln;
end;
s:=0;
min:= a[1,1];
max:= a[1,1];
for i:= 1 to n do
for j:= 1 to n do
if a[i,j]<min then min := a[i,j]; {поиск минимального элемента }
for i:= 1 to n do
for j:= 1 to n do
if a[i,j]> max then max:= a [i,j]; {поиск максимального элемента}
for i:=1 to n do
for j:= 1 to n do
if i=j then s:= s+a[i,j]; { поиск элементов главной диагонали и нахождение их суммы}
writeln('min=',min, ' max=',max,' summa elementov glavnoi dioganali=',s);
readln;
end.
Для решения данной задачи вам понадобится написать программу на языке Pascal. В программе вы будете искать максимальный и минимальный элементы матрицы, а также сумму диагональных элементов.
Поиск максимального и минимального элементов матрицы
Для поиска максимального и минимального элементов матрицы вам нужно будет пройти по всем элементам матрицы и сравнить их со значениями текущего максимального и минимального элементов.Вот пример программы, которая выполняет эту задачу:
```pascal program MaxMinMatrix;
const N = 3; // размерность матрицы
var matrix: array[1..N, 1..N] of Integer; i, j, maxElement, minElement: Integer;
begin // Заполнение матрицы writeln('Введите элементы матрицы:'); for i := 1 to N do begin for j := 1 to N do begin write('Элемент [', i, '][', j, ']: '); readln(matrix[i, j]); end; end;
// Поиск максимального и минимального элементов maxElement := matrix[1, 1]; minElement := matrix[1, 1]; for i := 1 to N do begin for j := 1 to N do begin if matrix[i, j] > maxElement then maxElement := matrix[i, j]; if matrix[i, j] < minElement then minElement := matrix[i, j]; end; end;
// Вывод результатов writeln('Максимальный элемент: ', maxElement); writeln('Минимальный элемент: ', minElement);
readln; end. ```
Поиск суммы диагональных элементов
Для поиска суммы диагональных элементов матрицы вам нужно будет пройти по элементам главной диагонали (элементы с одинаковыми индексами) и суммировать их значения.Вот пример программы, которая выполняет эту задачу:
```pascal program DiagonalSum;
const N = 3; // размерность матрицы
var matrix: array[1..N, 1..N] of Integer; i, j, diagonalSum: Integer;
begin // Заполнение матрицы writeln('Введите элементы матрицы:'); for i := 1 to N do begin for j := 1 to N do begin write('Элемент [', i, '][', j, ']: '); readln(matrix[i, j]); end; end;
// Поиск суммы диагональных элементов diagonalSum := 0; for i := 1 to N do begin diagonalSum := diagonalSum + matrix[i, i]; end;
// Вывод результата writeln('Сумма диагональных элементов: ', diagonalSum);
readln; end. ```
Объединение программ в одну
Чтобы объединить оба функционала в одну программу, вы можете просто скопировать код из обоих примеров в один файл. Вот пример объединенной программы:```pascal program MatrixOperations;
const N = 3; // размерность матрицы
var matrix: array[1..N, 1..N] of Integer; i, j, maxElement, minElement, diagonalSum: Integer;
begin // Заполнение матрицы writeln('Введите элементы матрицы:'); for i := 1 to N do begin for j := 1 to N do begin write('Элемент [', i, '][', j, ']: '); readln(matrix[i, j]); end; end;
// Поиск максимального и минимального элементов maxElement := matrix[1, 1]; minElement := matrix[1, 1]; for i := 1 to N do begin for j := 1 to N do begin if matrix[i, j] > maxElement then maxElement := matrix[i, j]; if matrix[i, j] < minElement then minElement := matrix[i, j]; end; end;
// Поиск суммы диагональных элементов diagonalSum := 0; for i := 1 to N do begin diagonalSum := diagonalSum + matrix[i, i]; end;
// Вывод результатов writeln('Максимальный элемент: ', maxElement); writeln('Минимальный элемент: ', minElement); writeln('Сумма диагональных элементов: ', diagonalSum);
readln; end. ```
Надеюсь, эта информация будет полезной для вас! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
